dev-ml/llvm-ocaml: Bump to 10.0.0rc2
[gentoo.git] / dev-ml / oasis / oasis-0.4.8.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_TESTS=1
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 MY_P=${P/_/\~}
12 DESCRIPTION="Tool to integrate a configure, build and install system in OCaml project"
13 HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
14 SRC_URI="http://forge.ocamlcore.org/frs/download.php/1669/${MY_P}.tar.gz"
15
16 LICENSE="LGPL-2.1-with-linking-exception"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
22         dev-ml/ocamlbuild:=[ocamlopt]"
23 DEPEND="${RDEPEND}
24         >=dev-ml/findlib-1.3.1
25         dev-ml/ocamlify
26         dev-ml/ocamlmod
27         !<sci-chemistry/oasis-4.0-r3
28         test? (
29                 >=dev-ml/ocaml-fileutils-0.4.2
30                 >=dev-ml/ounit-2.0.0
31                 >=dev-ml/ocaml-expect-0.0.4
32                 dev-ml/pcre-ocaml
33                 dev-ml/extlib
34         )"
35
36 RESTRICT+=" strip"
37 S="${WORKDIR}/${MY_P}"
38 DOCS=( "README.md" "TODO.txt" "AUTHORS.md" "CHANGES.txt" )