dev-ml/oasis: Bump to 0.4.10
[gentoo.git] / dev-ml / oasis / oasis-0.4.10.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_TESTS=1
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 MY_P=${P/_/\~}
12 DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
13 HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
14 SRC_URI="http://forge.ocamlcore.org/frs/download.php/1694/${MY_P}.tar.gz"
15
16 LICENSE="LGPL-2.1-with-linking-exception"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
22         dev-ml/ocamlbuild:=[ocamlopt]
23         dev-ml/camlp4:=
24 "
25 DEPEND="${RDEPEND}
26         >=dev-ml/findlib-1.3.1
27         dev-ml/ocamlify
28         dev-ml/ocamlmod
29         !<sci-chemistry/oasis-4.0-r3
30         test? (
31                 >=dev-ml/ocaml-fileutils-0.4.2
32                 >=dev-ml/ounit-2.0.0
33                 >=dev-ml/ocaml-expect-0.0.4
34                 dev-ml/pcre-ocaml
35                 dev-ml/extlib
36         )"
37
38 STRIP_MASK="*/bin/*"
39 S="${WORKDIR}/${MY_P}"
40 DOCS=( "README.md" "TODO.txt" "AUTHORS.md" "CHANGES.txt" )