dev-ml/*: Remove first set of unneeded leaf packages
[gentoo.git] / dev-ml / menhir / menhir-20171013.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib eutils
7
8 DESCRIPTION="LR(1) parser generator for the OCaml language"
9 HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
10 SRC_URI="http://gallium.inria.fr/~fpottier/menhir/${P}.tar.gz"
11
12 LICENSE="GPL-2 LGPL-2-with-linking-exception"
13 SLOT="0/${PV}"
14 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~x86"
15 IUSE="examples +ocamlopt"
16
17 RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
18 DEPEND="${RDEPEND}
19         dev-ml/ocamlbuild"
20
21 src_configure() {
22         if ! use ocamlopt ; then
23                 export TARGET=byte
24         fi
25 }
26
27 src_compile() {
28         emake PREFIX="${EPREFIX}"/usr -j1
29 }
30
31 src_install() {
32         findlib_src_preinst
33         emake PREFIX="${ED}"/usr docdir="${ED}"/usr/share/doc/"${PF}" $(use examples || echo "DOCS=manual.pdf") install
34         use examples && docompress -x /usr/share/doc/${PF}/demos
35         dodoc README.md CHANGES.md
36 }