dev-ml/llvm-ocaml: Bump to 10.0.0
[gentoo.git] / dev-ml / markup / markup-0.7.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib eutils
7
8 DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
9 HOMEPAGE="https://github.com/aantron/markup.ml"
10 SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}p1"
14 KEYWORDS="~amd64"
15 IUSE="doc test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="
19         dev-lang/ocaml:=[ocamlopt]
20         dev-ml/lwt:=[ocamlopt(+)]
21         >=dev-ml/uutf-1.0:=[ocamlopt]
22 "
23 RDEPEND="${DEPEND}"
24 DEPEND="${DEPEND}
25         test? ( dev-ml/ounit )
26         dev-ml/ocamlbuild"
27 S="${WORKDIR}/${PN}.ml-${PV}"
28
29 src_compile() {
30         emake
31         use doc && emake docs
32 }
33
34 src_install() {
35         findlib_src_preinst
36         emake ocamlfind-install
37         dodoc README.md
38         use doc && dohtml doc/html/*
39 }