dev-ml/findlib: ia64 stable wrt bug #708874
[gentoo.git] / dev-ml / lwt_ssl / lwt_ssl-1.1.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit opam
7
8 DESCRIPTION="GLib integration for Lwt"
9 SRC_URI="https://github.com/ocsigen/lwt/archive/${P}.tar.gz"
10 HOMEPAGE="http://ocsigen.org/lwt"
11
12 IUSE=""
13
14 RDEPEND="
15         >=dev-ml/lwt-3.1:=
16         >=dev-ml/ocaml-ssl-0.4.0:=
17 "
18 DEPEND="${RDEPEND}
19         dev-ml/jbuilder"
20
21 SLOT="0/${PV}"
22 LICENSE="LGPL-2.1-with-linking-exception"
23 KEYWORDS="~amd64 ~arm ~ppc"
24 S="${WORKDIR}/lwt-${P}/"
25
26 src_compile() {
27         jbuilder build -p ${PN} || die
28 }
29
30 src_test() {
31         jbuilder runtest -p ${PN} || die
32 }