dev-ml/lablgtk: remove old 2.18.8-r0
[gentoo.git] / dev-ml / lwt / lwt-3.0.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_TESTS=1
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 DESCRIPTION="Cooperative light-weight thread library for OCaml"
12 SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
13 HOMEPAGE="http://ocsigen.org/lwt"
14
15 IUSE="+camlp4 +ppx"
16
17 DEPEND="
18         dev-libs/libev
19         >=dev-lang/ocaml-4.02:=
20         dev-ml/result:=
21         ppx? ( dev-ml/ppx_tools:= )
22         camlp4? ( dev-ml/camlp4:= )"
23
24 RDEPEND="${DEPEND}
25         !<www-servers/ocsigen-1.1"
26 DEPEND="${DEPEND}
27         dev-ml/cppo"
28
29 SLOT="0/${PV}"
30 LICENSE="LGPL-2.1-with-linking-exception"
31 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
32
33 DOCS=( "CHANGES" "README.md" )
34
35 src_configure() {
36         oasis_configure_opts="
37                 --disable-glib
38                 --disable-react
39                 --disable-ssl
40                 $(use_enable camlp4)
41                 $(use_enable ppx)" \
42                 oasis_src_configure
43 }