dev-ml/num: x86 stable wrt bug #723500
[gentoo.git] / dev-ml / logs / logs-0.6.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit findlib
7
8 DESCRIPTION="Logging infrastructure for OCaml"
9 HOMEPAGE="http://erratique.ch/software/logs https://github.com/dbuenzli/logs"
10 SRC_URI="http://erratique.ch/software/logs/releases/${P}.tbz"
11
12 LICENSE="ISC"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="javascript +fmt cli +lwt test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         dev-ml/result:=[ocamlopt]
20         dev-lang/ocaml:=[ocamlopt]
21         javascript? ( dev-ml/js_of_ocaml:= )
22         fmt? ( dev-ml/fmt:= )
23         cli? ( dev-ml/cmdliner:=[ocamlopt] )
24         lwt? ( dev-ml/lwt:= )
25 "
26 DEPEND="${RDEPEND}
27         dev-ml/opam
28         dev-ml/topkg
29         dev-ml/ocamlbuild
30         dev-ml/findlib
31         test? ( dev-ml/mtime )
32 "
33
34 src_compile() {
35         ocaml pkg/pkg.ml build \
36                 --with-js_of_ocaml $(usex javascript true false) \
37                 --with-fmt $(usex fmt true false) \
38                 --with-cmdliner $(usex cli true false) \
39                 --with-lwt $(usex fmt true false) \
40                 --tests $(usex test true false) \
41                 || die
42 }
43
44 src_test() {
45         ocaml pkg/pkg.ml test || die
46 }
47
48 src_install() {
49         opam-installer -i \
50                 --prefix="${ED}/usr" \
51                 --libdir="${D}/$(ocamlc -where)" \
52                 --docdir="${ED}/usr/share/doc/${PF}" \
53                 ${PN}.install || die
54         dodoc CHANGES.md README.md
55 }