dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ml / jsonm / jsonm-1.0.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit findlib
7
8 DESCRIPTION="Non-blocking streaming JSON codec for OCaml"
9 HOMEPAGE="http://erratique.ch/software/jsonm"
10 SRC_URI="http://erratique.ch/software/jsonm/releases/${P}.tbz"
11
12 LICENSE="ISC"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
15 IUSE=""
16
17 RDEPEND=">=dev-ml/uutf-1.0.0:=
18         dev-lang/ocaml:=
19         dev-ml/uchar:="
20 DEPEND="${RDEPEND}
21         dev-ml/topkg
22         dev-ml/ocamlbuild
23         dev-ml/findlib"
24
25 DOCS=( CHANGES README )
26
27 src_compile() {
28         ocaml pkg/pkg.ml build || die
29 }
30
31 src_install() {
32         # Can't use opam-installer here as it is an opam dep...
33         findlib_src_preinst
34         local nativelibs="$(echo _build/src/${PN}.cm{x,xa,xs,ti} _build/src/${PN}.a)"
35         ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
36         newbin _build/test/jsontrip.native jsontrip
37         dodoc CHANGES.md TODO.md README.md
38 }