dev-ml/num: fix dependency
[gentoo.git] / dev-ml / js-build-tools / js-build-tools-113.33.06.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_DOCS=1
7 OASIS_BUILD_TESTS=1
8
9 inherit oasis
10
11 DESCRIPTION="Collection of tools to help building Jane Street Packages"
12 HOMEPAGE="https://github.com/janestreet/js-build-tools"
13 SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64"
18 IUSE=""
19
20 RDEPEND="dev-ml/ocamlbuild:="
21 DEPEND="${RDEPEND} dev-ml/opam"
22
23 src_configure() {
24         emake setup.exe
25         OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
26 }
27
28 src_compile() {
29         emake
30 }
31
32 src_install() {
33         opam-installer -i \
34                 --prefix="${ED}/usr" \
35                 --libdir="${D}/$(ocamlc -where)" \
36                 --docdir="${ED}/usr/share/doc/${PF}" \
37                 ${PN}.install || die
38         dodoc README.md
39 }