dev-ml/ppx_here: Bump to 0.9.0
[gentoo.git] / dev-ml / incremental_kernel / incremental_kernel-113.33.00.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit oasis
7
8 DESCRIPTION="Library for incremental computations depending only on Core_kernel"
9 HOMEPAGE="http://www.janestreet.com/ocaml"
10 SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 DEPEND="
18         dev-ml/bin-prot:=
19         >=dev-ml/core_kernel-113.33:=
20         dev-ml/fieldslib:=
21         dev-ml/ppx_assert:=
22         dev-ml/ppx_bench:=
23         dev-ml/ppx_expect:=
24         dev-ml/ppx_inline_test:=
25         dev-ml/ppx_jane:=
26         dev-ml/sexplib:=
27         dev-ml/typerep:=
28         dev-ml/variantslib:=
29 "
30 RDEPEND="${DEPEND}"
31 DEPEND="${DEPEND} dev-ml/opam"
32
33 src_configure() {
34         emake setup.exe
35         OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
36 }
37
38 src_compile() {
39         emake
40 }
41
42 src_install() {
43         opam-installer -i \
44                 --prefix="${ED}/usr" \
45                 --libdir="${D}/$(ocamlc -where)" \
46                 --docdir="${ED}/usr/share/doc/${PF}" \
47                 ${PN}.install || die
48 }