dev-ml/num: add for newer ocaml + coq
[gentoo.git] / dev-ml / iTeML / iTeML-2.5.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="Inline (Unit) Tests for OCaml"
9 HOMEPAGE="https://github.com/vincent-hugot/iTeML"
10 SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="dev-ml/ounit:=
18         dev-lang/ocaml:=[ocamlopt]
19         >=dev-ml/qcheck-0.5:=
20 "
21 DEPEND="${RDEPEND}
22         dev-ml/ocamlbuild
23 "
24
25 src_install() {
26         findlib_src_preinst
27         dodir /usr/bin
28         emake BIN="${ED}/usr/bin/" install
29         dodoc README.adoc HOWTO.adoc
30 }