dev-ml/zarith: using AR
[gentoo.git] / dev-ml / gsl-ocaml / gsl-ocaml-1.19.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_DOCS=1
7 OASIS_BUILD_TESTS=1
8
9 inherit oasis
10
11 DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
12 HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
13 SRC_URI="https://github.com/mmottl/${PN}/releases/download/v${PV}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="examples test"
19 RESTRICT="!test? ( test )"
20
21 DEPEND=">=sci-libs/gsl-1.19"
22 RDEPEND="${DEPEND}
23         !dev-ml/ocamlgsl"
24
25 DOCS=( CHANGES.txt README.md NOTES.md TODO.md )
26
27 src_prepare() {
28         oasis_configure_opts="$(use_enable examples)"
29 }