dev-ml/num: x86 stable wrt bug #723500
[gentoo.git] / dev-ml / fpath / fpath-0.7.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit opam
7
8 DESCRIPTION="File system paths for OCaml"
9 HOMEPAGE="http://erratique.ch/software/fpath https://github.com/dbuenzli/fpath"
10 SRC_URI="http://erratique.ch/software/fpath/releases/${P}.tbz"
11
12 LICENSE="ISC"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 RDEPEND="
18         dev-ml/result:=
19         dev-ml/astring:=
20 "
21 DEPEND="${RDEPEND}
22         dev-ml/topkg
23         dev-ml/ocamlbuild
24         dev-ml/findlib
25 "
26
27 src_compile() {
28         ocaml pkg/pkg.ml build || die
29 }