dev-ml/llvm-ocaml: Enable py3.8
[gentoo.git] / dev-ml / easy-format / easy-format-1.0.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="Pretty-printing library for OCaml"
9 HOMEPAGE="http://mjambon.com/easy-format.html"
10 SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
11
12 SLOT="0/${PV}"
13 LICENSE="BSD"
14 KEYWORDS="~amd64"
15
16 IUSE="examples +ocamlopt"
17
18 RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
19 DEPEND="${RDEPEND}"
20
21 src_compile() {
22         emake all
23         use ocamlopt && emake opt
24 }
25
26 src_install() {
27         findlib_src_install
28         dodoc README.md Changes
29         if use examples ; then
30                 dodoc -r examples
31                 docompress -x /usr/share/doc/${PF}/examples
32         fi
33 }