dev-ml/dune: arm64 stable (#710374)
[gentoo.git] / dev-ml / deriving / deriving-0.7.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_TESTS=1
7
8 inherit oasis
9
10 DESCRIPTION="A deriving library for Ocsigen"
11 HOMEPAGE="https://github.com/ocsigen/deriving"
12 SRC_URI="https://github.com/ocsigen/deriving/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0/${PV}"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 RDEPEND="
20         >=dev-ml/type-conv-108:=
21         dev-ml/optcomp:=
22         dev-ml/findlib:=
23         dev-ml/camlp4:=
24 "
25 DEPEND="${RDEPEND}
26         dev-ml/oasis"
27
28 DOCS=( CHANGES README.md )
29 oasis_configure_opts="--enable-tc"
30 OASIS_SETUP_COMMAND="./setup.exe"
31
32 src_configure() {
33         emake setup.exe
34         oasis_src_configure
35 }