Merge remote-tracking branch 'github/pr/703'. Fixes bug 560362.
[gentoo.git] / dev-ml / cryptokit / cryptokit-1.7.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 DESCRIPTION="Cryptographic primitives library for Objective Caml"
12 HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
13 SRC_URI="http://forge.ocamlcore.org/frs/download.php/1166/${P}.tar.gz"
14 LICENSE="LGPL-2"
15 SLOT="0/${PV}"
16 KEYWORDS="amd64 ppc x86 ~x86-fbsd"
17 IUSE="zlib"
18
19 DEPEND="zlib? ( >=sys-libs/zlib-1.1 )"
20 RDEPEND="${DEPEND}"
21
22 DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
23
24 src_configure() {
25         oasis_configure_opts="$(use_enable zlib)" \
26                 oasis_src_configure
27 }
28
29 pkg_postinst() {
30         elog ""
31         elog "This library uses the /dev/random device to generate "
32         elog "random data and RSA keys.  The device should either be"
33         elog "built into the kernel or provided as a module. An"
34         elog "alternative is to use the Entropy Gathering Daemon"
35         elog "(http://egd.sourceforge.net).  Please note that the"
36         elog "remainder of the library will still work even in the"
37         elog "absence of a one of these sources of randomness."
38         elog ""
39 }
40
41 src_test() {
42         echo ""
43         einfo "You must have either /dev/random or the Entropy Gathering"
44         einfo "Daemon (EGD) for this test to succeed!"
45         echo ""
46
47         oasis_src_test
48 }