dev-ml/llvm-ocaml: Remove unused WITH_POLLY
[gentoo.git] / dev-ml / cryptokit / cryptokit-1.11.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 OASIS_BUILD_DOCS=1
7 OASIS_BUILD_TESTS=1
8
9 inherit oasis
10
11 DESCRIPTION="Cryptographic primitives library for Objective Caml"
12 HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
13 SRC_URI="http://forge.ocamlcore.org/frs/download.php/1618/${P}.tar.gz"
14 LICENSE="LGPL-2"
15 SLOT="0/${PV}"
16 KEYWORDS="~amd64 ~ppc ~x86"
17 IUSE="zlib"
18
19 DEPEND="zlib? ( >=sys-libs/zlib-1.1 )
20         dev-ml/zarith:="
21 RDEPEND="${DEPEND}"
22
23 DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
24 REQUIRED_USE="test? ( ocamlopt )"
25
26 src_configure() {
27         oasis_configure_opts="$(use_enable zlib)" \
28                 oasis_src_configure
29 }
30
31 pkg_postinst() {
32         elog ""
33         elog "This library uses the /dev/random device to generate "
34         elog "random data and RSA keys.  The device should either be"
35         elog "built into the kernel or provided as a module. An"
36         elog "alternative is to use the Entropy Gathering Daemon"
37         elog "(http://egd.sourceforge.net).  Please note that the"
38         elog "remainder of the library will still work even in the"
39         elog "absence of a one of these sources of randomness."
40         elog ""
41 }
42
43 src_test() {
44         echo ""
45         einfo "You must have either /dev/random or the Entropy Gathering"
46         einfo "Daemon (EGD) for this test to succeed!"
47         echo ""
48
49         oasis_src_test
50 }