dev-ml/camlpdf: version bump to 2.3.1
[gentoo.git] / dev-ml / core_bench / core_bench-0.9.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Micro-benchmarking library for OCaml"
7 HOMEPAGE="https://github.com/janestreet/core_bench"
8 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0/${PV}"
12 KEYWORDS="~amd64"
13 IUSE=""
14
15 RDEPEND="
16         dev-lang/ocaml:=
17         dev-ml/core:=
18         dev-ml/core_extended:=
19         dev-ml/ppx_driver:=
20         dev-ml/ppx_jane:=
21         dev-ml/textutils:=
22         dev-ml/ocaml-migrate-parsetree:=
23         dev-ml/ocaml-re:=
24 "
25 DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
26
27 src_install() {
28         opam-installer -i \
29                 --prefix="${ED}/usr" \
30                 --libdir="${D}/$(ocamlc -where)" \
31                 --docdir="${ED}/usr/share/doc/${PF}" \
32                 ${PN}.install || die
33 }