Merge the GLEP 67 transition changes
[gentoo.git] / dev-ml / core / core-113.00.00.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 OASIS_BUILD_DOCS=1
8 OASIS_BUILD_TESTS=1
9
10 inherit eutils oasis
11
12 MY_P=${P/_/\~}
13 DESCRIPTION="Jane Street's alternative to the standard library"
14 HOMEPAGE="http://www.janestreet.com/ocaml"
15 SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
16
17 LICENSE="LGPL-2.1-with-linking-exception"
18 SLOT="0/${PV}"
19 KEYWORDS="~amd64"
20 IUSE=""
21
22 RDEPEND="
23         >=dev-ml/core_kernel-109.35.00:=
24         >=dev-ml/sexplib-109.20.00:=
25         >=dev-ml/bin-prot-109.15.00:=
26         >=dev-ml/fieldslib-109.20.00:=
27         >=dev-ml/pa_ounit-109.27.00:=
28         >=dev-ml/variantslib-109.15.00:=
29         >=dev-ml/comparelib-109.27.00:=
30         >=dev-ml/herelib-109.35.00:=
31         >=dev-ml/pipebang-109.15.00:=
32         dev-ml/custom_printf:=
33         dev-ml/pa_bench:=
34         dev-ml/pa_test:=
35         dev-ml/enumerate:=
36         dev-ml/camlp4:=
37         dev-ml/pa_structural_sexp:=
38         "
39 DEPEND="${RDEPEND}
40         test? ( >=dev-ml/ounit-1.1.2 )"
41 DOCS=( "README.md" )