dev-ml/num: amd64 stable wrt bug #723500
[gentoo.git] / dev-ml / configurator / configurator-0.9.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Helper library for gathering system configuration"
7 HOMEPAGE="https://github.com/janestreet/configurator"
8 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0/${PV}"
12 KEYWORDS="~amd64 ~ppc ~x86"
13 IUSE=""
14
15 DEPEND="
16         dev-lang/ocaml:=
17         dev-ml/base:=
18         dev-ml/ppx_base:=
19         dev-ml/ppx_driver:=
20         dev-ml/stdio:=
21         dev-ml/ocaml-migrate-parsetree:=
22         "
23 RDEPEND="${DEPEND}"
24 DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
25
26 src_install() {
27         opam-installer -i \
28                 --prefix="${ED}/usr" \
29                 --libdir="${D}/$(ocamlc -where)" \
30                 --docdir="${ED}/usr/share/doc/${PF}" \
31                 ${PN}.install || die
32 }