dev-ml/dune: arm stable wrt bug #710374
[gentoo.git] / dev-ml / camomile / camomile-0.8.5-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib eutils
7
8 DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
9 HOMEPAGE="https://github.com/yoriyuki/Camomile/wiki"
10 SRC_URI="https://github.com/yoriyuki/Camomile/releases/download/rel-${PV}/${P}.tar.bz2"
11
12 LICENSE="LGPL-2"
13 SLOT="0/${PV}"
14 KEYWORDS="amd64 ppc x86"
15 IUSE="debug +ocamlopt"
16
17 RDEPEND="
18         >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
19         dev-ml/camlp4:=
20 "
21 DEPEND="${RDEPEND}"
22
23 src_prepare() {
24         has_version '>=dev-lang/ocaml-4.05_beta' && epatch "${FILESDIR}/ocaml405.patch"
25 }
26
27 src_configure() {
28         econf $(use_enable debug)
29 }
30
31 src_compile() {
32         emake -j1 byte unidata unimaps charmap_data locale_data
33         if use ocamlopt; then
34                 emake -j1 opt
35         fi
36 }
37
38 src_install() {
39         dodir /usr/bin
40         findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
41 }