dev-ml/camlp5: amd64 stable wrt bug #709348
[gentoo.git] / dev-ml / camlzip / camlzip-1.06.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit findlib eutils
7
8 IUSE="+ocamlopt"
9
10 DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
11 HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
12 SRC_URI="http://forge.ocamlcore.org/frs/download.php/1616/${P}.tar.gz"
13
14 SLOT="1/${PV}"
15 LICENSE="LGPL-2.1"
16 KEYWORDS="amd64 ppc x86"
17
18 RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
19                 >=sys-libs/zlib-1.1.3"
20 DEPEND="${RDEPEND}"
21
22 src_compile() {
23         emake all
24         if use ocamlopt; then
25                 emake allopt
26         fi
27 }
28
29 src_install() {
30         findlib_src_preinst
31         emake DESTDIR="${D}" install-findlib
32
33         dodoc README Changes
34 }