dev-ml/ppx_tools: backport upstream fixes for ocaml 4.04
[gentoo.git] / dev-ml / camlzip / camlzip-1.06.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit findlib eutils
8
9 IUSE="+ocamlopt"
10
11 DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
12 HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
13 SRC_URI="http://forge.ocamlcore.org/frs/download.php/1616/${P}.tar.gz"
14
15 SLOT="1/${PV}"
16 LICENSE="LGPL-2.1"
17 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
18
19 RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
20                 >=sys-libs/zlib-1.1.3"
21 DEPEND="${RDEPEND}"
22
23 src_compile() {
24         emake all
25         if use ocamlopt; then
26                 emake allopt
27         fi
28 }
29
30 src_install() {
31         findlib_src_preinst
32         emake DESTDIR="${D}" install-findlib
33
34         dodoc README Changes
35 }