dev-ml/camlp5: remove old versions
[gentoo.git] / dev-ml / camldbm / camldbm-1.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit base
7
8 DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
9 HOMEPAGE="http://forge.ocamlcore.org/projects/camldbm/"
10 SRC_URI="http://forge.ocamlcore.org/frs/download.php/728/${P}.tgz"
11
12 LICENSE="LGPL-2-with-linking-exception"
13 SLOT="0/${PV}"
14 KEYWORDS="amd64 arm ppc x86"
15 IUSE=""
16
17 DEPEND=">=sys-libs/gdbm-1.9.1-r2[berkdb]
18         >=dev-lang/ocaml-3.12:=[ocamlopt]"
19 RDEPEND="${DEPEND}"
20
21 PATCHES=( "${FILESDIR}/hasgotfix.patch" "${FILESDIR}/include_fix.patch" )
22
23 src_install() {
24         dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
25         emake LIBDIR="${D}/$(ocamlc -where)" install
26         dodoc README Changelog
27 }