dev-ml/camlp4: Version bump (v4.08_p1)
[gentoo.git] / dev-ml / bos / bos-0.1.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Basic OS interaction for OCaml"
7 HOMEPAGE="http://erratique.ch/software/bos https://github.com/dbuenzli/bos"
8 SRC_URI="http://erratique.ch/software/bos/releases/${P}.tbz"
9
10 LICENSE="ISC"
11 SLOT="0/${PV}"
12 KEYWORDS="~amd64"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         dev-lang/ocaml:=
18         dev-ml/rresult:=
19         dev-ml/astring:=
20         dev-ml/fpath:=
21         dev-ml/fmt:=
22         dev-ml/logs:=
23 "
24 DEPEND="${RDEPEND}
25         dev-ml/findlib
26         dev-ml/ocamlbuild
27         dev-ml/topkg
28         test? ( dev-ml/mtime )
29 "
30
31 src_compile() {
32         ocaml pkg/pkg.ml build --tests $(usex test true false) || die
33 }
34
35 src_test() {
36         ocaml pkg/pkg.ml test || die
37 }
38
39 src_install() {
40         opam-installer -i \
41                 --prefix="${ED}/usr" \
42                 --libdir="${D}/$(ocamlc -where)" \
43                 --docdir="${ED}/usr/share/doc/${PF}" \
44                 ${PN}.install || die
45 }