dev-ml/lablgtk: remove old 2.18.8-r0
[gentoo.git] / dev-ml / biniou / biniou-1.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
9 HOMEPAGE="https://github.com/mjambon/biniou"
10 SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 SLOT="0/${PV}"
13 LICENSE="BSD"
14 KEYWORDS="~amd64"
15 IUSE="+ocamlopt"
16
17 RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
18         dev-ml/easy-format:=[ocamlopt?]
19 "
20 DEPEND="${RDEPEND}
21         dev-ml/jbuilder
22         dev-ml/opam
23 "
24
25 src_install() {
26         opam-installer -i \
27                 --prefix="${ED}/usr" \
28                 --libdir="${D}/$(ocamlc -where)" \
29                 --docdir="${ED}/usr/share/doc/${PF}" \
30                 --mandir="${ED}/usr/share/man" \
31                 ${PN}.install || die
32 }