dev-ml/llvm-ocaml: 10.x branch is now 10.0.1
[gentoo.git] / dev-ml / biniou / biniou-1.0.13.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
9 HOMEPAGE="https://github.com/mjambon/biniou"
10 SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 SLOT="0/${PV}"
13 LICENSE="BSD"
14 KEYWORDS="~amd64"
15 IUSE="+ocamlopt"
16
17 RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
18         dev-ml/easy-format:=[ocamlopt?]
19 "
20 DEPEND="${RDEPEND}"
21
22 src_compile() {
23         emake all
24         use ocamlopt && emake opt
25 }
26
27 src_install() {
28         use ocamlopt && dodir /usr/bin
29         findlib_src_install BINDIR="${ED}"/usr/bin
30         dodoc README.md Changes
31 }