dev-ml/llvm-ocaml: AVR is now mainline target
[gentoo.git] / dev-ml / bin-prot / bin-prot-0.9.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Binary protocol generator"
7 HOMEPAGE="https://github.com/janestreet/bin_prot"
8 SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0/${PV}"
12 KEYWORDS="~amd64"
13 IUSE=""
14
15 RDEPEND="
16         dev-lang/ocaml:=
17         dev-ml/base:=
18         dev-ml/ppx_compare:=
19         dev-ml/ppx_custom_printf:=
20         dev-ml/ppx_core:=
21         dev-ml/ppx_driver:=
22         dev-ml/ppx_fields_conv:=
23         dev-ml/ppx_sexp_conv:=
24         dev-ml/ppx_type_conv:=
25         dev-ml/ppx_variants_conv:=
26         dev-ml/sexplib:=
27         dev-ml/ocaml-migrate-parsetree:=
28 "
29 DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
30
31 S="${WORKDIR}/bin_prot-${PV}"
32
33 src_test() {
34         jbuilder runtest || die
35 }
36
37 src_install() {
38         opam-installer -i \
39                 --prefix="${ED}/usr" \
40                 --libdir="${D}/$(ocamlc -where)" \
41                 --docdir="${ED}/usr/share/doc/${PF}" \
42                 ${PN/-/_}.install || die
43         dodoc CHANGES.md README.md
44 }