dev-ml/findlib: x86 stable wrt bug #708874
[gentoo.git] / dev-ml / batteries / batteries-2.7.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit oasis eutils
7
8 DESCRIPTION="The community-maintained foundation library for your OCaml projects"
9 HOMEPAGE="https://github.com/ocaml-batteries-team/batteries-included/"
10 SRC_URI="https://github.com/ocaml-batteries-team/batteries-included/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1-with-linking-exception"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="dev-ml/camomile:="
19 DEPEND="${RDEPEND}
20         test? ( dev-ml/ounit dev-ml/iTeML )"
21
22 DOCS=( "ChangeLog" "FAQ" "README.folders" "README.md" )
23
24 S="${WORKDIR}/${PN}-included-${PV}"