dev-ml/ppx_tools: bumped to 5.3.4.08.0 + eapi7
[gentoo.git] / dev-ml / base / base-0.9.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Standard library for OCaml"
7 HOMEPAGE="https://github.com/janestreet/base"
8 SRC_URI="https://github.com/janestreet/base/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0/${PV}"
12 KEYWORDS="~amd64"
13 IUSE=""
14
15 RDEPEND="
16         dev-lang/ocaml:=
17         dev-ml/sexplib:=
18         <dev-ml/sexplib-100
19 "
20 DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
21
22 src_test() {
23         jbuilder runtest || die
24 }
25
26 src_install() {
27         opam-installer -i \
28                 --prefix="${ED}/usr" \
29                 --libdir="${D}/$(ocamlc -where)" \
30                 --docdir="${ED}/usr/share/doc/${PF}" \
31                 ${PN}.install || die
32         dodoc ROADMAP.md README.org
33 }