dev-ml/{camlimages,js_of_ocaml,labltk}: Dependency default
[gentoo.git] / dev-ml / atd / atd-1.2.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit findlib
7
8 DESCRIPTION="Syntax for cross-language type definitions"
9 HOMEPAGE="https://github.com/mjambon/atd"
10 SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="+ocamlopt"
16
17 DEPEND="
18         dev-lang/ocaml:=[ocamlopt?]
19         dev-ml/easy-format:=[ocamlopt?]
20         dev-ml/menhir:=[ocamlopt?]
21 "
22 RDEPEND="${DEPEND}"
23 DEPEND="${DEPEND}
24         dev-ml/jbuilder
25         dev-ml/opam
26 "
27
28 src_install() {
29         opam-installer -i \
30                 --prefix="${ED}/usr" \
31                 --libdir="${D}/$(ocamlc -where)" \
32                 --docdir="${ED}/usr/share/doc/${PF}" \
33                 ${PN}.install || die
34 }