dev-ml/llvm-ocaml: Remove 9.0.1 RCs and live
[gentoo.git] / dev-ml / atd / atd-1.12.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit findlib
7
8 DESCRIPTION="Syntax for cross-language type definitions"
9 HOMEPAGE="https://github.com/mjambon/atd"
10 SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="+ocamlopt test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="
19         dev-lang/ocaml:=[ocamlopt?]
20         dev-ml/easy-format:=[ocamlopt?]
21         dev-ml/menhir:=[ocamlopt?]
22 "
23 RDEPEND="${DEPEND}"
24 DEPEND="${DEPEND}
25         dev-ml/jbuilder
26         dev-ml/opam
27         test? (
28                 dev-ml/biniou
29                 dev-ml/yojson
30         )
31 "
32
33 src_compile() {
34         jbuilder build -p atd || die
35 }
36
37 oinstall() {
38         opam-installer -i \
39                 --prefix="${ED}/usr" \
40                 --libdir="${D}/$(ocamlc -where)" \
41                 --docdir="${ED}/usr/share/doc/${PF}" \
42                 ${1}.install || die
43 }
44
45 src_install() {
46         oinstall atd
47 }