*/*: Drop stable ia64 keywords
[gentoo.git] / dev-ml / async_extra / async_extra-0.9.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
7 HOMEPAGE="https://github.com/janestreet/async_extra"
8 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0/${PV}"
12 KEYWORDS="~amd64"
13 IUSE=""
14
15 RDEPEND=">=dev-lang/ocaml-4.02.0:=
16         dev-ml/async_kernel:=
17         dev-ml/async_rpc_kernel:=
18         dev-ml/async_unix:=
19         dev-ml/core:=
20         dev-ml/ppx_driver:=
21         dev-ml/ppx_jane:=
22         dev-ml/ocaml-migrate-parsetree:=
23 "
24 DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
25
26 src_install() {
27         opam-installer -i \
28                 --prefix="${ED}/usr" \
29                 --libdir="${D}/$(ocamlc -where)" \
30                 --docdir="${ED}/usr/share/doc/${PF}" \
31                 ${PN}.install || die
32 }