*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ml / angstrom-unix / angstrom-unix-0.7.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit opam
7
8 DESCRIPTION="Parser combinators built for speed and memory efficiency"
9 HOMEPAGE="https://github.com/inhabitedtype/angstrom"
10 SRC_URI="https://github.com/inhabitedtype/angstrom/archive/${PV}.tar.gz -> angstrom-${PV}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 RDEPEND="dev-ml/angstrom:="
18 DEPEND="${RDEPEND}
19         dev-ml/jbuilder"
20
21 S="${WORKDIR}/angstrom-${PV}"
22
23 src_compile() {
24         jbuilder build -p ${PN} || die
25 }
26
27 src_test() {
28         jbuilder runtest -p ${PN}
29 }