dev-ml/lablgtk: revbump 2.18.8, EAPI-7, fix CI issue, restore KEYWORDS
[gentoo.git] / dev-ml / alcotest / alcotest-0.8.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit opam
7
8 DESCRIPTION="A lightweight and colourful test framework"
9 HOMEPAGE="https://github.com/mirage/alcotest/"
10 SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         dev-ml/fmt:=
20         dev-ml/astring:=
21         dev-ml/cmdliner:=
22         dev-ml/result:=
23 "
24 DEPEND="${RDEPEND}
25         dev-ml/jbuilder
26         dev-ml/findlib"
27
28 src_compile() {
29         jbuilder build -p alcotest || die
30 }
31
32 src_test() {
33         jbuilder runtest -p alcotest || die
34 }