profiles: hppa: Drop obsolete net-libs/libssh revdeps p.use.stable.mask
[gentoo.git] / dev-lua / luasocket / luasocket-3.0_rc1-r3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit multilib multilib-minimal flag-o-matic
7
8 DESCRIPTION="Networking support library for the Lua language"
9 HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/"
10 SRC_URI="https://github.com/diegonehab/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 arm ~arm64 hppa ~mips ppc ppc64 sparc x86"
15 IUSE="debug"
16
17 RDEPEND=">=dev-lang/lua-5.1.5-r2[deprecated,${MULTILIB_USEDEP}]"
18 DEPEND="${RDEPEND}
19         >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
20
21 S=${WORKDIR}/${PN}-${PV/_/-}
22
23 RESTRICT="test"
24
25 src_prepare() {
26         multilib_copy_sources
27 }
28
29 multilib_src_compile() {
30         emake \
31                 CC="$(tc-getCC) ${CFLAGS}" \
32                 LD="$(tc-getCC) ${LDFLAGS}"\
33                 $(usex debug DEBUG="DEBUG" "")
34 }
35
36 multilib_src_install() {
37         local luav=$($(tc-getPKG_CONFIG) --variable V lua)
38         emake \
39                 DESTDIR="${D}" \
40                 LUAPREFIX_linux=/usr \
41                 LUAV=${luav} \
42                 CDIR_linux=$(get_libdir)/lua/${luav} \
43                 install-unix
44 }
45
46 multilib_src_install_all() {
47         dodoc NEW README
48         dohtml -r doc/.
49 }