dev-lua/luajson: amd64 stable wrt bug #676486
[gentoo.git] / dev-lua / luajson / luajson-1.3.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="JSON Parser/Constructor for Lua"
7 HOMEPAGE="https://www.eharning.us/wiki/luajson/"
8 SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ppc ppc64 sparc x86"
13 IUSE="test"
14
15 RDEPEND="|| ( >=dev-lang/lua-5.1 dev-lang/luajit:2 )
16         dev-lua/lpeg"
17 DEPEND="test? ( dev-lua/luafilesystem )"
18
19 # lunit not in the tree yet
20 RESTRICT="test"
21
22 # nothing to compile
23 src_compile() { :; }
24
25 src_install() {
26         emake PREFIX=/usr DESTDIR="${D}" install
27         dodoc README docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt
28 }