sys-apps/prctl: drop old
[gentoo.git] / dev-lua / busted / busted-2.0_rc12_p1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 # The below is the upstream version number. The -x suffix should be kept
9 # in sync with the _px suffix in the ebuild version.
10 MY_PV="2.0.rc12-1"
11
12 DESCRIPTION="Elegant Lua unit testing"
13 HOMEPAGE="http://olivinelabs.com/busted/"
14 SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="amd64 arm ppc ppc64 x86"
19 IUSE=""
20
21 COMMON_DEPEND=">=dev-lang/lua-5.1:="
22 DEPEND="${COMMON_DEPEND}
23 virtual/pkgconfig"
24 RDEPEND="${COMMON_DEPEND}
25         >=dev-lua/lua_cliargs-3.0
26         >=dev-lua/luafilesystem-1.5.0
27         >=dev-lua/luasystem-0.2.0
28         >=dev-lua/dkjson-2.1.0
29         >=dev-lua/say-1.3
30         >=dev-lua/luassert-1.7.8
31         >=dev-lua/lua-term-0.1_p1
32         >=dev-lua/penlight-1.3.2
33         >=dev-lua/mediator_lua-1.1.1_p0
34 "
35
36 S="${WORKDIR}/${PN}-${MY_PV}"
37
38 src_install() {
39         dobin bin/busted
40         insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
41         doins -r busted/*
42         dodoc *.md
43 }