net-analyzer/knocker: Port to EAPI 7
[gentoo.git] / dev-lua / busted / busted-2.0_rc11_p0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 # The below is the upstream version number. The -x suffix should be kept
9 # in sync with the _px suffix in the ebuild version.
10 MY_PV="2.0.rc11-0"
11
12 DESCRIPTION="Elegant Lua unit testing"
13 HOMEPAGE="http://olivinelabs.com/busted/"
14 SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 COMMON_DEPEND=">=dev-lang/lua-5.1:="
22 DEPEND="${COMMON_DEPEND}
23 virtual/pkgconfig"
24 RDEPEND="${COMMON_DEPEND}
25         ~dev-lua/lua_cliargs-2.5_p5
26         >=dev-lua/luafilesystem-1.5.0
27         >=dev-lua/dkjson-2.1.0
28         >=dev-lua/say-1.3
29         >=dev-lua/luassert-1.7.8
30         >=dev-lua/lua-term-0.1_p1
31         >=dev-lua/penlight-1.3.2
32         >=dev-lua/mediator_lua-1.1.1_p0
33         >=dev-lua/luasocket-2.0.1
34 "
35
36 S="${WORKDIR}/${PN}-${MY_PV}"
37
38 src_install() {
39 dobin bin/busted
40 insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
41 doins -r busted/*
42 dodoc *.md
43 }