net-dns/bind: stable 9.12.2_p2-r1 for ppc64, bug #657654
[gentoo.git] / dev-lisp / clx / clx-0.7.5.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit common-lisp-3 eutils
7
8 DESCRIPTION="CLX is the Common Lisp interface to the X11 protocol primarily for SBCL."
9 HOMEPAGE="http://www.cliki.net/CLX"
10 SRC_URI="https://github.com/sharplispers/clx/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
15 IUSE="doc"
16
17 DEPEND="sys-apps/texinfo
18                 doc? ( virtual/texi2dvi )"
19 RDEPEND="!dev-lisp/cl-${PN}"
20
21 src_compile() {
22         cd manual || die
23         makeinfo ${PN}.texinfo -o ${PN}.info || die
24         if use doc ; then
25                 VARTEXFONTS="${T}"/fonts \
26                         texi2pdf ${PN}.texinfo -o ${PN}.pdf || die
27         fi
28 }
29
30 src_install() {
31         common-lisp-install-sources *.lisp debug demo extensions tests
32         common-lisp-install-asdf
33         dodoc NEWS CHANGES README*
34         doinfo manual/${PN}.info
35         use doc && dodoc manual/${PN}.pdf
36 }