dev-libs/libofx: bump package
[gentoo.git] / dev-libs / zookeeper-c / zookeeper-c-3.4.8.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="C client interface to Zookeeper server"
7 HOMEPAGE="https://zookeeper.apache.org/"
8 SRC_URI="mirror://apache/zookeeper/zookeeper-${PV}/zookeeper-${PV}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0"
12 KEYWORDS="~amd64"
13 IUSE="doc static-libs test"
14
15 RDEPEND=""
16 DEPEND="${RDEPEND}
17         doc? ( app-doc/doxygen )
18         test? ( dev-util/cppunit )"
19
20 S="${WORKDIR}/zookeeper-${PV}/src/c"
21
22 src_configure() {
23         econf \
24                 $(use_enable static-libs static) \
25                 $(use_with test cppunit)
26 }
27
28 src_compile() {
29         emake
30         use doc && emake doxygen-doc
31 }
32
33 src_install() {
34         default
35         use doc && dohtml docs/html/*
36 }