dev-libs/zlog: Revbump to 1.2.12-r1, handle libdir properly #628732
[gentoo.git] / dev-libs / zlog / zlog-1.2.12.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils
7
8 DESCRIPTION="A reliable, thread safe, clear-model, pure C logging library."
9 HOMEPAGE="http://hardysimpson.github.io/zlog/"
10 SRC_URI="https://github.com/HardySimpson/${PN}/archive/${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 DEPEND=""
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         default_src_prepare
22         epatch "${FILESDIR}/zlog_no_werr.patch"
23 }
24
25 src_test () {
26         emake test || die "Tests failed."
27 }
28
29 src_install() {
30         emake PREFIX="${D}/usr" install
31 }