dev-libs/yajl: stable 2.1.0-r1 for sparc, bug #664216
[gentoo.git] / dev-libs / yajl / yajl-2.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils cmake-multilib vcs-snapshot
7
8 DESCRIPTION="Small event-driven (SAX-style) JSON parser"
9 HOMEPAGE="https://lloyd.github.com/yajl/"
10 SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0/2"
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="static-libs"
16
17 src_prepare() {
18         cmake-utils_src_prepare
19
20         multilib_copy_sources
21 }
22
23 src_test() {
24         run_test() {
25                 cd "${BUILD_DIR}"/test/parsing
26                 ./run_tests.sh ./yajl_test || die
27         }
28         multilib_parallel_foreach_abi run_test
29 }
30
31 src_install() {
32         cmake-multilib_src_install
33
34         use static-libs || \
35                 find "${D}" -name libyajl_s.a -delete
36 }