dev-libs/yajl: arm stable wrt bug #685884
[gentoo.git] / dev-libs / yajl / yajl-2.1.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-multilib vcs-snapshot
7
8 DESCRIPTION="Small event-driven (SAX-style) JSON parser"
9 HOMEPAGE="https://lloyd.github.com/yajl/"
10 SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0/2"
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="static-libs"
16
17 PATCHES=( "${FILESDIR}"/${P}-uclibc.patch )
18
19 src_prepare() {
20         cmake-utils_src_prepare
21
22         multilib_copy_sources
23 }
24
25 src_test() {
26         run_test() {
27                 cd "${BUILD_DIR}"/test/parsing
28                 ./run_tests.sh ./yajl_test || die
29         }
30         multilib_parallel_foreach_abi run_test
31 }
32
33 src_install() {
34         cmake-multilib_src_install
35
36         use static-libs || \
37                 find "${D}" -name libyajl_s.a -delete
38 }