Use https by default
[gentoo.git] / dev-libs / yajl / yajl-1.0.11.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=2
6
7 inherit cmake-utils
8
9 DESCRIPTION="Small event-driven (SAX-style) JSON parser"
10 HOMEPAGE="http://lloyd.github.com/yajl/"
11 SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 arm hppa ppc ppc64 x86"
16
17 IUSE=""
18
19 CMAKE_IN_SOURCE_BUILD="1"
20
21 src_prepare() {
22         cd "${WORKDIR}"/lloyd-${PN}-*
23         S=$(pwd)
24
25         epatch "${FILESDIR}"/${PN}-fix_tests.patch
26 }
27
28 src_test() {
29         emake test
30 }