dev-libs/boost: Rekeyword and unleash into unstable
[gentoo.git] / dev-libs / weston / weston-1.10.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [[ ${PV} = 9999* ]]; then
8         EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
9         GIT_ECLASS="git-r3"
10         EXPERIMENTAL="true"
11 fi
12 VIRTUALX_REQUIRED="test"
13 RESTRICT="test"
14
15 inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
16
17 DESCRIPTION="Wayland reference compositor"
18 HOMEPAGE="https://wayland.freedesktop.org/"
19
20 if [[ $PV = 9999* ]]; then
21         SRC_URI="${SRC_PATCHES}"
22         KEYWORDS=""
23 else
24         SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
25         KEYWORDS="~amd64 ~arm ~x86 ~arm-linux"
26 fi
27
28 LICENSE="MIT CC-BY-SA-3.0"
29 SLOT="0"
30
31 IUSE_VIDEO_CARDS="video_cards_intel video_cards_v4l"
32 IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland ${IUSE_VIDEO_CARDS}"
33
34 REQUIRED_USE="
35         drm? ( gles2 )
36         screen-sharing? ( rdp )
37         test? ( X )
38         wayland-compositor? ( gles2 )
39 "
40
41 RDEPEND="
42         >=dev-libs/libinput-0.8.0
43         >=dev-libs/wayland-1.9.90
44         >=dev-libs/wayland-protocols-1.0
45         lcms? ( media-libs/lcms:2 )
46         media-libs/libpng:0=
47         media-libs/libwebp:0=
48         virtual/jpeg:0=
49         >=x11-libs/cairo-1.11.3
50         >=x11-libs/libdrm-2.4.30
51         x11-libs/libxkbcommon
52         x11-libs/pixman
53         x11-misc/xkeyboard-config
54         fbdev? (
55                 >=sys-libs/mtdev-1.1.0
56                 >=virtual/udev-136
57         )
58         colord? ( >=x11-misc/colord-0.1.27 )
59         dbus? ( sys-apps/dbus )
60         drm? (
61                 media-libs/mesa[gbm]
62                 >=sys-libs/mtdev-1.1.0
63                 >=virtual/udev-136
64         )
65         editor? ( x11-libs/pango )
66         gles2? (
67                 media-libs/mesa[gles2,wayland]
68         )
69         rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
70         rpi? (
71                 >=sys-libs/mtdev-1.1.0
72                 >=virtual/udev-136
73         )
74         systemd? (
75                 sys-auth/pambase[systemd]
76                 sys-apps/systemd[pam]
77         )
78         launch? ( sys-auth/pambase )
79         unwind? ( sys-libs/libunwind )
80         X? (
81                 x11-libs/libxcb
82                 x11-libs/libX11
83         )
84         xwayland? (
85                 x11-base/xorg-server[wayland]
86                 x11-libs/cairo[xcb]
87                 x11-libs/libxcb
88                 x11-libs/libXcursor
89         )
90 "
91 DEPEND="${RDEPEND}
92         virtual/pkgconfig
93 "
94
95 src_prepare() {
96         if [[ ${PV} = 9999* ]]; then
97                 eautoreconf
98         fi
99 }
100
101 src_configure() {
102         local myconf
103         if use examples || use test; then
104                 myconf="--enable-simple-clients"
105         else
106                 myconf="--disable-simple-clients"
107         fi
108
109         myconf+=" --with-cairo=image --disable-simple-egl-clients"
110
111         econf \
112                 $(use_enable examples demo-clients-install) \
113                 $(use_enable fbdev fbdev-compositor) \
114                 $(use_enable dbus) \
115                 $(use_enable drm drm-compositor) \
116                 $(use_enable headless headless-compositor) \
117                 $(use_enable ivi ivi-shell) \
118                 $(use_enable lcms) \
119                 $(use_enable rdp rdp-compositor) \
120                 $(use_enable rpi rpi-compositor) \
121                 $(use_enable wayland-compositor) \
122                 $(use_enable X x11-compositor) \
123                 $(use_enable launch weston-launch) \
124                 $(use_enable colord) \
125                 $(use_enable gles2 egl) \
126                 $(use_enable unwind libunwind) \
127                 $(use_enable resize-optimization) \
128                 $(use_enable screen-sharing) \
129                 $(use_enable suid setuid-install) \
130                 $(use_enable xwayland) \
131                 $(use_enable xwayland xwayland-test) \
132                 $(use_enable video_cards_intel simple-dmabuf-intel-client) \
133                 $(use_enable video_cards_v4l simple-dmabuf-v4l-client) \
134                 ${myconf}
135 }
136
137 src_test() {
138         export XDG_RUNTIME_DIR="${T}/runtime-dir"
139         mkdir "${XDG_RUNTIME_DIR}" || die
140         chmod 0700 "${XDG_RUNTIME_DIR}" || die
141
142         cd "${BUILD_DIR}" || die
143         Xemake check
144 }
145
146 src_install() {
147         default
148
149         readme.gentoo_create_doc
150 }