dev-libs/wayland-protocols: stable 1.16 for sparc, bug #668900
[gentoo.git] / dev-libs / wayland-protocols / wayland-protocols-1.14.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} = 9999* ]]; then
7         EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
8         EXPERIMENTAL="true"
9
10         inherit git-r3 autotools
11 else
12         inherit autotools
13 fi
14
15 DESCRIPTION="Wayland protocol files"
16 HOMEPAGE="https://wayland.freedesktop.org/"
17
18 if [[ $PV != 9999* ]]; then
19         SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
20         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
21 fi
22
23 LICENSE="MIT"
24 SLOT="0"
25 IUSE=""
26
27 RDEPEND="dev-libs/wayland"
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig"
30
31 src_prepare() {
32         default
33
34         [[ ${PV} == 9999 ]] && eautoreconf
35 }
36
37 src_test() {
38         export XDG_RUNTIME_DIR="${T}/runtime-dir"
39         mkdir "${XDG_RUNTIME_DIR}" || die
40         chmod 0700 "${XDG_RUNTIME_DIR}" || die
41
42         default
43 }