dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / volume_key / volume_key-0.3.11.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit python-single-r1
9
10 DESCRIPTION="Library for manipulating and storing storage volume encryption keys"
11 HOMEPAGE="https://pagure.io/volume_key"
12 SRC_URI="http://releases.pagure.org/${PN}/${P}.tar.xz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 RDEPEND="
22         ${PYTHON_DEPS}
23         app-crypt/gpgme
24         dev-libs/glib:2
25         dev-libs/nspr
26         dev-libs/nss
27         sys-apps/util-linux
28         sys-fs/cryptsetup:=
29 "
30 DEPEND="
31         ${RDEPEND}
32         sys-devel/gettext
33         test? ( dev-libs/nss[utils] )
34         "
35
36 #RESTRICT="test" # possible gpgme issue
37
38 pkg_setup() {
39         python-single-r1_pkg_setup
40 }
41
42 src_install() {
43         default
44         find "${ED}" -name "*.la" -delete || die
45 }