dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / dev-libs / userspace-rcu / userspace-rcu-0.9.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-utils
7
8 DESCRIPTION="userspace RCU (read-copy-update) library"
9 HOMEPAGE="https://liburcu.org/"
10 SRC_URI="https://lttng.org/files/urcu/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0/4" # subslot = soname version
14 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
15 IUSE="static-libs regression-test test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="test? ( sys-process/time )"
19
20 # tests fail with separate build dir
21 AUTOTOOLS_IN_SOURCE_BUILD=1
22
23 src_configure() {
24         local myeconfargs=(
25                 --docdir="${EPREFIX}/usr/share/doc/${PF}"
26         )
27         autotools-utils_src_configure
28 }
29
30 src_test() {
31         default
32         if use regression-test; then
33                 emake -C tests/regression regtest
34         fi
35 }