dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-libs / userspace-rcu / userspace-rcu-0.10.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="userspace RCU (read-copy-update) library"
7 HOMEPAGE="https://liburcu.org/"
8 SRC_URI="https://lttng.org/files/urcu/${P}.tar.bz2"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0/6" # subslot = soname version
12 KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
13 IUSE="static-libs regression-test test"
14 RESTRICT="!test? ( test )"
15
16 DEPEND="test? ( sys-process/time )"
17
18 src_configure() {
19         local myeconfargs=(
20                 --enable-shared
21                 $(use_enable static-libs static)
22         )
23         econf "${myeconfargs[@]}"
24 }
25
26 src_test() {
27         default
28         if use regression-test; then
29                 emake -C tests/regression regtest
30         fi
31 }